Installation de OpenWrt sur le routeur TP-Link N600

Installation de OpenWrt sur le routeur TP-Link N600.

Matériel : TP-Link N600
Référence : TL-WDR3600

1) Répertoire de travail :

[~] ➔ mkdir -p MATERIEL/TPLINKN600
[~] ➔ cd MATERIEL/TPLINKN600/

2) Déballage :

2015-10-18 10.13.45

2015-10-18 10.23.52

3) Monté :

2015-10-18 10.17.06

2015-10-18 10.24.37

4) Sur l’ordinateur portable, la connexion Internet est active.

5) Télécharger Openwrt : openwrt-ar71xx-generic-tl-wdr3600-v1-squashfs-factory.bin

[~/MATERIEL/TPLINKN600] ➔ wget http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/openwrt-ar71xx-generic-tl-wdr3600-v1-squashfs-factory.bin

6) Se déconnecter d’Internet

7) Brancher le routeur (eth1) sur l’ordinateur portable (eth0)

8) Allumer le routeur.

9) Assigner l’adresse ip 192.168.0.2 à l’ordinateur portable :

[~/MATERIEL/TPLINKN600] ➔ sudo ifconfig eth0 192.168.0.2 netmask 255.255.255.0

10) Vérification :

[~/MATERIEL/TPLINKN600] ➔ ifconfig
eth0      Link encap:Ethernet  HWaddr 14:58:d0:04:c6:76  
          inet adr:192.168.0.2  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::1658:d0ff:fe04:c676/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:7853 erreurs:0 :0 overruns:0 frame:0
          TX packets:4533 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:10070412 (10.0 MB) Octets transmis:384498 (384.4 KB)

11) Lancer un navigateur internet puis aller à l’adresse : http://192.168.0.1

12) Une fenêtre d’authentication apparaît :

Utilisateur : admin
Mot de passe : admin

Valider : [OK]

Page d’accueil de l’interface d’administration par défaut du routeur :

routeur01

13) Clique sur [System Tools] puis [Firmware Upgrade]

routeur02

14) Cliquer sur [Parcourir] et sélectionner le fichier : openwrt-ar71xx-generic-tl-wdr3600-v1-squashfs-factory.bin

routeur03

Puis [Ouvrir]

15) Cliquer sur [Upgrade]

routeur04

Valider la mise-à-jour : [OK]

routeur05

16) La mise-à jour s’effectue.

routeur06

Puis le redémarrage :

routeur07

17) La mise-à-jour a été correctement effectué :

routeur071

18) Après quelques secondes, il y a une perte de connexion entre l’ordinateur et le routeur

routeur08

19) Assigner l’adresse ip : 192.168.1.2

[~/MATERIEL/TPLINKN600] ➔ sudo ifconfig eth0 192.168.1.2 netmask 255.255.255.0

20) Vérification :

[~/MATERIEL/TPLINKN600] ➔ ifconfig
eth0      Link encap:Ethernet  HWaddr 14:58:d0:04:c6:76  
          inet adr:192.168.1.2  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::1658:d0ff:fe04:c676/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:13839 erreurs:0 :0 overruns:0 frame:0
          TX packets:12515 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:11658292 (11.6 MB) Octets transmis:9099001 (9

21) Connexion au routeur : http://192.168.1.1

routeur09

22) (Après la modification du mot de passe roor) Page d’accueil de OpenWrt :

routeur10

23) Happy Geeking !!! :d

24) Liens :

http://www.tp-link.fr/products/details/?model=TL-WDR3600
https://openwrt.org/
http://wiki.openwrt.org/toh/tp-link/tl-wdr3600

[TL-WR710N] Installation de Samba

[TL-WR710N] Installation de Samba.

1) Formatage de la clé usb :

Système de fichiers : ext4
Etiquette : partage1

2) Copier un fichier sur la clé usb.

3) Insérer la clé dans le routeur.

4) Mise-à-jour de la base de donnée des paquetages :

root@OpenWrt:~# opkg update

5) Installation des modules USB :

root@OpenWrt:~# opkg install kmod-usb-storage block-mount kmod-nls-cp437 kmod-nls-iso8859-1

6) Installation du serveur Samba :

root@OpenWrt:~# opkg install luci-app-samba

7) Installation du support vfat :

root@OpenWrt:~# opkg install kmod-fs-vfat

8) Installation du support ext4 :

root@OpenWrt:~# opkg install kmod-fs-ext4

9) Installation du support btrfs :

root@OpenWrt:~# opkg install kmod-fs-btrfs

10) Activation de Samba :

root@OpenWrt:~# /etc/init.d/samba enable

11) Démarrer Samba :

root@OpenWrt:~# /etc/init.d/samba start

12) Redémarrer le routeur :

root@OpenWrt:~# reboot

13) Configuration du partage :

A partir de l’interface graphique LUCI.

[System][Mount Points]
– Mount Points :
– Sélectionne le point de montage
[Edit]
– Enable this mount : V
Device : /dev/sda1
Mount point : /mnt/sda1
Filesystem : ext4
[Save & Apply]

14) Initialiser le partage :

[Services][Network Shares][Add]
– Name : Partage
Path : /mnt/sda1
Allow guests : V
[Add]
[Save & Apply]

15) Redémarrer le service Samba :

[System][Startup]
– samba : [Restart]

16) Modifier les permissions du partage :

root@OpenWrt:~# chmod 777 /mnt/sda1/

17) Visualiser le partage :

Sous Ubuntu :

[Raccourcis][Réseau]
[OPENWRT][partage]

18) Le partage est accessible en lecture et écriture.

19) Liens :

http://grade2linux.wordpress.com/2013/05/10/tp-link-tl-wr1043nd-openwrt-ch07_samba_file_server/
http://wiki.openwrt.org/doc/recipes/usb-storage-samba-webinterface
http://wiki.openwrt.org/doc/howto/usb.storage
http://ediy.com.my/index.php/blog/item/28-tp-link-tl-wr1043nd-as-a-samba-file-server

[TL-WR710N] Installation de l’interface graphique LUCI

Installation de l’interface graphique LUCI.

1) Mise-à-jour des paquetages :

root@OpenWrt:~# opkg update

2) Installation de LUCI :

root@OpenWrt:~# opkg install luci
Installing luci (svn-r10532-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/luci/luci_svn-r10532-1_ar71xx.ipk.
Installing uhttpd (2014-08-25-dabd7dea6445aaa0e5b8d9add1872fa7393b3a85) to root...                         
...
Installing liblua (5.1.5-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/base/liblua_5.1.5-1_ar71xx.ipk.
Installing libuci-lua (2014-04-11.1-1) to root...
...
Configuring liblua.
Configuring libuci-lua.
Configuring libubus-lua.
...
Configuring luci.
root@OpenWrt:~#

3) Activer le daemon httpd :

root@OpenWrt:~# /etc/init.d/uhttpd enable
root@OpenWrt:~# /etc/init.d/uhttpd start

4) Redémarrer le routeur :

root@OpenWrt:~# reboot

5) Sous un navigateur web, lancer l’interface : http://192.168.1.200/cgi-bin/luci

Fenêtre de connexion :

capture009

Taper le mot de passe root : mot2passe
Puis [Login].

capture011

6) Lien :

http://bluemarmot.ekibox.net/en/node/57

[TL-WR710N] Changement d’adresse ip

Changement d’adresse ip.

1) Branchement :

Routeur TL-WWR710N / Port LAN <--> Ordinateur / Port eth0

2) Connexion en ssh :

[~] ➔ ssh root@192.168.1.1
root@192.168.1.1's password:


BusyBox v1.22.1 (2014-09-18 14:05:13 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42608)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:~#

3) Modification de l’adresse ip :

– Remplacer l’adresse du routeur par : 192.168.1.200
– Ajouter le gateway : 192.168.1.1
– Ajouter le dns de Google : 8.8.8.8

Ouvrir :

/etc/config/network

Chercher :

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

Remplacer par :

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.200'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'

4) Redémarrer le réseau :

root@OpenWrt:~# /etc/init.d/network restart

5) Connexion vers le routeur avec sa nouvelle adresse ip :

[~] ➔ ssh root@192.168.1.200
The authenticity of host '192.168.1.200 (192.168.1.200)' can't be established.
RSA key fingerprint is 94:7a:3c:c4:fe:e3:7c:f6:b7:31:67:e0:43:24:b7:e1.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.200' (RSA) to the list of known hosts.
root@192.168.1.200's password:


BusyBox v1.22.1 (2014-09-18 14:05:13 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42608)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:~#

6) Brancher le routeur et l’ordinateur sur la box internet.

7) Connexion en ssh sur le routeur :

[~] ➔ ssh root@192.168.1.200
...
root@OpenWrt:~#

8) Teste de la connexion internet :

root@OpenWrt:~# ping -c 5 ardenne-informatique.com
PING ardenne-informatique.com (5.135.181.217): 56 data bytes
64 bytes from 5.135.181.217: seq=0 ttl=51 time=37.121 ms
64 bytes from 5.135.181.217: seq=1 ttl=51 time=36.891 ms
64 bytes from 5.135.181.217: seq=2 ttl=51 time=36.902 ms
64 bytes from 5.135.181.217: seq=3 ttl=51 time=37.442 ms
64 bytes from 5.135.181.217: seq=4 ttl=51 time=36.751 ms

--- ardenne-informatique.com ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 36.751/37.021/37.442 ms
root@OpenWrt:~#

9) Liens :

http://cmikavac.net/2012/06/03/tp-link-wr703n-openwrt-post-installation-tips/
http://bluemarmot.ekibox.net/en/node/58

Mise-à-jour du micro-logiciel du routeur TP-Link TL-WR710N vers OpenWrt

Mise-à-jour du micro-logiciel du routeur TP-Link TL-WR710N vers OpenWrt.

Modèle: TL-WR710N(EU)
Version : 1.2

A partir de l’ordinateur :

1) Répertoire de travail :

[~] ➔ mkdir TP
[~] ➔ cd TP/
[~/TP] ➔ 

2) Téléchargement du micro-logiciel :

La connexion internet est active.

[~/TP] ➔ wget http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr710n-v1-squashfs-factory.bin
[~/TP] ➔ ls -l *.bin
-rw-rw-r-- 1 util01 util01 8126464 sept. 18 16:29 openwrt-ar71xx-generic-tl-wr710n-v1-squashfs-factory.bin

3) Branchement :

– Débrancher la connexion internet de l’ordinateur.

– Brancher le routeur sur une prise électrique.

– Relier le routeur TL-WR710N vers l’ordinateur (non-connecté à Internet).

Port LAN du routeur TL-WR710N <--> Port eth0 de l’ordinateur.

– Allumer le routeur et ensuite l’ordinateur.

4) Configuration de l’adresse ip de l’ordinateur :

[~] ➔ ifconfig eth0 192.168.0.2 netmask 255.255.255.0 up
[~] ➔ ifconfig
eth0      Link encap:Ethernet  HWaddr e0:cb:4e:c1:71:73  
          inet adr:192.168.0.2  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::e2cb:4eff:fec1:7173/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:547608 erreurs:0 :0 overruns:0 frame:0
          TX packets:367919 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:703895000 (703.8 MB) Octets transmis:61455283 (61.4 MB)
          Interruption:45 Adresse de base:0xa000 
...

5) A partir d’un navigateur internet, se connecter à l’interface d’administration du routeur : http://192.168.0.254

Une fenêtre de login s’affiche :

capture01

Utilisateur : admin
Mot de passe : admin

capture02

L’interface d’administration s’affiche :

capture03

6) Mise-à-jour de micro-logiciel :

[System Tools] -> [Firmware Upgrade]

capture04

Lien direct : http://192.168.0.254/userRpm/SoftwareUpgradeRpm.htm

7) Sélectionner le micro-logiciel OpenWrt :

[Parcourir]

– Sélectionner : openwrt-ar71xx-generic-tl-wr710n-v1-squashfs-factory.bin

capture05

[Valider]

[Upgrade]

capture06

– Confirmer la mise-à-jour : [OK]

capture07

– La mise-à-jour s’effectue.

capture08

Après quelques seconde, le routeur redémarre.

8) Changer d’adresse ip de l’ordinateur :

[~] ➔ ifconfig eth0 192.168.1.2 netmask 255.255.255.0 up

9) Connection en telnet vers le routeur :

[~/TP] ➔ telnet 192.168.1.1
Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.
 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.22.1 (2014-09-18 14:05:13 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42608)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/#

10) Changer le mot de passe :

root@OpenWrt:/# passwd
Changing password for root
New password:
Bad password: too weak
Retype password:
Password for root changed by root
root@OpenWrt:/#

Ssh est activé et Telnet est désactivé.

11) Quitter OpenWrt :

root@OpenWrt:/# exit
Connection closed by foreign host

12) Connection en ssh sur le routeur :

[~/TP] ➔ ssh root@192.168.1.1
The authenticity of host '192.168.1.1 (192.168.1.1)' can't be established.
RSA key fingerprint is 94:7a:3c:c4:fe:e3:7c:f6:b7:31:67:e0:43:24:b7:e1.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.1' (RSA) to the list of known hosts.
root@192.168.1.1's password:


BusyBox v1.22.1 (2014-09-18 14:05:13 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42608)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:~#

13) Redémarrage :

root@OpenWrt:/# reboot

14) Liens :

https://forum.openwrt.org/viewtopic.php?pid=215950#p215950
http://blog.stefanproell.at/2014/06/29/use-a-tp-link-tl-wr710n-router-as-a-repeater-with-openwrt/